RE: Anyone done anything with the Euphoria Source Code?
- Posted by bensler at mail.com Jan 19, 2002
- 452 views
My first project would be to add a symbol for slicing to the end of a sequence.. instead of writing: my_sequence[1..length(my_sequence)] you could write my_sequence[1..?], or maybe just [1..] I think it's more readable to have a symbol in there though.. By using a symbol, instead of a number, you avoid complications with slice checking. I haven't seen the source, but I would expect it to be one of the more straight forward revisions you could do. Another might be to add auto assignment of unassigned function calls. That's just candy though.. but should be fairly simple. In comparison to other mods anyways.. foo(a,b,c) would equate to; VOID = foo(a,b,c) You could also add support for trailing commas for declarations. Shouldn't be hard. When a new structure is found, the declaration is terminated. This would be greatly appreciated. I'm sure David would agree with this one ;) You might have to add a new structure to deal with this though, to avoid naming conflicts. Something like this... declare constant end declare Chris tone.skoda at siol.net wrote: > If I had source code I would add these things (in order of importance): > > 1. Simplified object orientation: > > A small example: > > include circle.e as circle > > circle circle1 > circle circle2 > > circle1.x = 100 > circle1.y = 100 > circle1.radius = 10 > > circle2.x = 200 > circle2.y = 200 > circle2.radius = 50 > > circle1.draw () > circle2.draw () > > Code above would draw two DIFFERENT circles. > > > 2. Visual debugger with treeviews for sequences. > > 3. Structures or something similar. To atleast turn this: > point [POINT_X] = x > into this: > point.x = x > > No other thing comes to mind this moment. > Feature that every routine must be before you call it is not so bad > thing. > It keeps your code more organized. gotos are not needed. Maybe > "continue" > statement. > >