Re: Euphoria Standard Library on UBoard

new topic     » goto parent     » topic index » view thread      » older message » newer message

Juergen Luethje wrote:
> I also think it's a good idea, for people who like to communicate on web
> forums. So thank you for supporting the ESL project!
> 
> I personally would highly prefer that we send e-mails, using the CC
> feature, for internal discussions. I think my e-mail provider even
> allows me to set up a mailing-list. So if we actually want to have an
> ESL mailing-list, I'll try to create it.
> 
> When there is substantial discussion on UBoard, we'll have to find a way
> how that stuff is included in the ESL papers:
> 
> a) Maybe someone posts a summary here on EUforum, so that I can do so.
>                 or
> b) probably better: Someone else will maintain the ESL papers.
>    1) We'll put the papers on a different website.
>                 or
>    2) The papers will stay where they are. Someone sends me the updated
>       HTML file(s), and I'll just upload them on my website.
> 
> Everything will be OK for me, except expecting me to participate in web
> forum discussions.

I agree, but the UBoard has some advantages: different topics can be
discussed in separate threads, all the posts are easily accessible
for everyone to read, and voting about a topic can be made easy via
the polling functionality UBoard offers.

> > I looked at Juergen web pages about ESL, and I have a small suggestion:
> > the guidelines tell us that it's better not to use abbreviations, but in
> > the math-page I see types like 'positive_int'. Wouldn't it be better to
> > use the full 'integer'-name?
> >  atom -> positive_atom; integer -> positive_integer
> 
> I'll soon change the file 'math.htm' accordingly (hoping this is OK for
> everyone).
> 
> I just want to mention that on the other hand, the module 'math.e' will
> contain several abbreviated routine names anyway;
>    ceil[ing]()
>    abs[olute value]()
>    min[imum]()
>    max[imum]()
>    log[arithm base]10()
>    sin[us]h[yperbolicus]()
>    ...
> 
> These abbreviations are standard math names, so we actually should use
> them. I just want to say that, if there is a good reason, we should
> consider using an abbreviation. One reason IMHO is, when the original
> name is very long.

You're right about that one. These abbreviations don't bother me, because
everybody uses them. And 'positive_int' wouldn't bother me if the integer-
type would be called 'int' in Euphoria. I just think it's a good idea to
have consistent naming conventions.

Here are some more suggestions I have for ESL:
- the constants TRUE and FALSE
- bitwise functions
- a mechanism to ignore return-values of functions. Some options:
  -> a global variable VOID: VOID = functionToIgnore(...) (like Win32Lib)
-> a procedure ignore that does nothing: ignore(functionToIgnore()) (like
  Win4Eu)
- an enumeration-mechanism: here's how it was done in Win4Eu:
 
constant DAY_OF_WEEK = enum()
  constant MONDAY = next(DAY_OF_WEEK),
           TUESDAY = next(DAY_OF_WEEK),
           WEDNESDAY = next(DAY_OF_WEEK),
           THURSDAY = next(DAY_OF_WEEK),
           FRIDAY = next(DAY_OF_WEEK),
           SATURDAY = next(DAY_OF_WEEK),
           SUNDAY = next(DAY_OF_WEEK)
  

- advanced C/API-interface functionality (WIN32/LINUX)

--
The Internet combines the excitement of typing 
with the reliability of anonymous hearsay.

tommy online: http://users.telenet.be/tommycarlier
tommy.blog: http://tommycarlier.blogspot.com

new topic     » goto parent     » topic index » view thread      » older message » newer message

Search



Quick Links

User menu

Not signed in.

Misc Menu