Re: Proposal for 'math.e' (2007-08-23)

new topic     » goto parent     » topic index » view thread      » older message » newer message

Sorry for the rather late reply.
There was no discussion about "math.e" for a week or more. So I thought
I'd just post the new version with two little changes that have been
discussed seperately before, but then ... smile

Pete Lomax wrote:

> Juergen Luethje wrote:
> 
>> This is my current (2007-08-23) proposal for a "math.e" standard
>> include file, according to the discussion here on EUforum.
>> 
>> 
>> global function find_min (sequence list, integer start)
>> global function find_max (sequence list, integer start)
>> global function min (sequence list, integer start)
>> global function max (sequence list, integer start)
>> global function lesser (object x1, object x2)
>> global function greater (object x1, object x2)
>> 
> I thought we had agreed these should be in a separate file, minmax.e.

My impression was that some people didn't like to have that in a
separate file. And I have to admit that I can't remember having read
about the name "minmax.e". However, the current favourite name obviously
is "compare.e". I think this name is actually better, since that file
will also be a good place e.g. for a find_binary() function and more.

> I do not
> remember and I cannot find anyone specifically objecting to that, other than
> CChris once saying he was "not sure" and "not against this split", and in the
> next post reinventing your "allinc" idea seemed to sway him.
> 
> I also thought the final outcome of that long discussion was a general
> agreement
> that no-one gets to use "min" and "max" to avoid ambiguity.

I wonder whether there will ever be a final outcome of that discussion. smile

Seriously:
Up to a certain point in time, there was (or seemed to be) such an
agreement. At that time we had (IIRC):
   global function least (sequence list, integer start)
   global function greatest (sequence list, integer start)
   global function lesser (object x1, object x2)
   global function greater (object x1, object x2)

Then came this post by Fernando Bauer:
<http://www.openeuphoria.org/cgi-bin/esearch.exu?fromMonth=6&fromYear=C&toMonth=8&toYear=C&postedBy=Fernando+Bauer&keywords=min2>
This post was the begin of a new round of the discussion.
Fernando actually suggested to use "min" and "min2" as initially
proposed by me. But I had the impression that some people especially
didn't like "min2". And then it also occured to me that probably the
_least confusion_ will be caused by using two completely different words.
So neither use  min/min2  nor  least/lesser, but  min/lesser  instead.
Up to now, no one has objected aginst that.

> I shall restate my exact position on this:
> I would not be too miffed if someone nicked the "min" name for a
> single-parameter
> function min(sequence list), but once it has two parameters, that is just
> asking
> for trouble.
> I also cannot imagine any, let alone many, cases where the functions min() and
> max() as posted would be useful, since they return a value not an index and
> I question what you would do once you've processed that item

Hu? Are you asking why statisticians want to get the minimum and maximum
values of a data collection?

> and how/why would you setup a suitable "start" value??

IIRC that was my idea. I was thinking of the fact, that it was necessary
to introduce a separate function find_from(), because find() was created
without a "start" parameter.
So I thought if we now create a min() function, then some time later we'd
introduce a function min_from(). smile
But maybe a "start" parameter actually doesn't make much sense in this
context.

Regards,
   Juergen

new topic     » goto parent     » topic index » view thread      » older message » newer message

Search



Quick Links

User menu

Not signed in.

Misc Menu