Re: Request: Integer Division
- Posted by jimcbrown (admin) Jan 02, 2013
- 1392 views
I wanted to just use the name intdiv() (since that's less typing than integer_division) which saves human time too - but that was already taken. I'm open to alternatives, though. idiv() perhaps?
It seems like we'd update the existing function to use whatever new implementation we came up with. If we're adding an operator, then the function would presumably become deprecated. If a machine func, then it would be the "official" wrapper for the machine func call.
I don't think I'd worry too much about backwards compatibility in the case of adding the operator, which I suspect would be the right way to go, since we'd presumably also add =\ as an operator and the performance and readability improvements those operators provide.
Matt
Ah, I didn't think about using the backslash as the low-level fast intdiv operator. I think this is the best approach.