forum-msg-id-132664-edit

Original date:2018-05-22 08:24:35 Edited by: SDPringle Subject: Re: Installing Euphoria in Linux Issue

I tried translating Euphoria 4.1 on 32-bit Linux with itself for 64-bit Linux to C. I then put the translated C source on a VPS host and tried to compile the C sources and I got an interpreter. But the interpreter crashes with a "segmentation fault" violation for every program it ran. To make matters worse, gdb doesn't show me any line information when I go to debug the interpreter itself even though I ran configure with the 'debug' option on the VPS host before compiling.

The SEGV signal is received while running the translated version of the routine my_sscanf. On my home system such a problem would be easy to find, as I would open gdb and it would show me the very line of code where the SEGV takes place. Not so on this VPS.

I tried to go the route of just taking a compiled binary and got a similar error to what you got Chris: "GLIB 2.15 not found".

Maybe these systems are just too out of date. For the benefit of those who are newer, this shouldn't happen (barring std/machine.e calls) with a translated Euphoria program. Even rebuilding an older released 4.1 version gives me an interpreter that SEGVs. I am just resigned to the idea that this VPS cannot do 4.1.

Not Categorized, Please Help

Search



Quick Links

User menu

Not signed in.

Misc Menu