forum-msg-id-130266-edit

Original date:2016-09-06 21:01:51 Edited by: lpuster Subject: Re: win32Lib Apps Crashing on Startup

A913 said...
rweavers said...

Exe programs built using Euphoria 3.1 and win32lib no longer function on my Dell laptop running Windows 7 Home Premium, service pack 1. Neither do the demo .exw demo examples that come with win32Lib. For example, attempting to run boxes.exw results in a message stating Win32Lib AppWindow Fatal error. Error code 482. CreateWindow in createWindow failed. Win32Lib v0.70.4. 17-Jun-2008. My computer then is in an unstable state and I need to restart. I suspect this recent behaviour is the result of something that has been changed by some newly installed software, but I am at a loss to know where to start looking for the cause. Any help would be gratefully accepted.

The problem is not with win32lib, rweavers, it is with Windows. When they changed over to a 64 bit system with the Vista OS, they changed the size of the handles, and that followed with each new revision up to Windows 7. I ran across this with all of the programs I wrote for Win98 or XP. When I switched all of my handle values to atoms instead of integers, the program would work fine without having to mess around with downward compatibility issues. It is for this reason that I dropped all Microsoft crap and went to Linux and FreeDOS. I don't like some corporation leading me around by the balls. What's next? Every time they want to corner the software market again, all they have to do is change the OS and all subsequent programs won't work anymore. That's exactly why all of you had to buy new peripherals, like printers or scanners, after the change over. HP, Lexmark, and the rest of them wouldn't update their drivers by increasing the handle size. The whole thing is a scam.

This is so frustrating. I have been using Euphoria for many years. At one time in the past, I had this problem, but after completely rebuilding my system and reloading all applications, the problem went away for a couple of years. I just finished developing an application last week in v3.1.1 (I have not yet tried v4) and now the problem is back. All of my Euphoria programs now fail. I restored my C: drive from an image when everything was working, and it still fails.

I made a test program from a section of my program (only the part that defines the window and controls) and it fails, even though I changed my test program to declare only sequences and atoms. No integers. I suppose Win32 Lib declares handles as integers, and that is the problem. I could translate my programs into v4, but I have no assurance of success. If nobody posts a solution for me, I will have to bid Euphoria a fond farewell. I am still puzzled why no other compiler or application that I know of has this problem.

It was the DEP setting. I have no idea how this setting survived a complete replacement of my C: drive via image, but it did. In Win7 the setting is found in Control Panel > System > Advanced System Settings > Advanced > Performance Settings > Data Executing Prevention. Choose "Turn on DEP for essential Windows Programs and services only" or choose the other radio button and figure out which program to exempt.

Not Categorized, Please Help

Search



Quick Links

User menu

Not signed in.

Misc Menu