Euphoria Ticket #427: Unable to build on windows

I just did a SVN update and the make file is not working.

I'm not near my computer at the moment so I can't supply the exact messages from make. However it seems to be complaining that when linking the euc program, the linker can't find any of the 'export'ed names that have been defined in error.e.


Type: Bug Report Severity: Blocking Category: Build System
Assigned To: unknown Status: Fixed Reported Release:
Fixed in SVN #: 4273 View VCS: 4273 Milestone: 4.0.0RC2

1. Comment by mattlewis Nov 22, 2010

Questions to fill in when you're back where you can answer them:

  • Is this from a clean build / checkout?
  • How did you configure?
  • How did you build (e.g., wmake all)?

2. Comment by DerekParnell Nov 22, 2010


Is this from a clean build / checkout?
How did you configure?
I ran configure with no options just prior to building.
How did you build (e.g., wmake all)?

3. Comment by jeremy Nov 22, 2010

What is your current version of eui? Not sure why that would matter but I was able to build on windows from a fresh build w/o issue.

C:\euphoria> eui --version 
Euphoria Interpreter 4.0.0 development (r4199) for Windows 
Using Managed Memory 
C:\euphoria> rmdir /s/q build 
C:\euphoria> cd source 
C:\euphoria> configure --build ..\build  
C:\euphoria> wmake 

all built fine.

4. Comment by euphoric Nov 22, 2010

My build of the latest (4264) gets stuck here:

del /Q c:\euphoria\source\build\intobj\*.* 
del /Q c:\euphoria\source\main-.h 
Could Not Find c:\euphoria\source\main-.h 
del /Q c:\euphoria\source\init-.c 
Could Not Find c:\euphoria\source\init-.c 
del /Q c:\euphoria\source\main-.c 
Could Not Find c:\euphoria\source\main-.c 
cd  c:\euphoria\source\build\intobj 
c:\euphoria\bin\eui.exe -i c:\euphoria\include   c:\euphoria\source\ec.ex  -nobu 
ild -wat -plat WIN  -D EU_MANAGED_MEM  -i c:\euphoria\include c:\euphoria\source 

I'm using the standard


to get it built. My current version is 4057.

5. Comment by DerekParnell Nov 23, 2010

Ok, so this time I deleted the build directory and repeated my steps.

It works now ... mostly.

Except that after bind was built, it couldn't delete that (bind) build directory.

6. Comment by jeremy Nov 23, 2010

Derek, I had the same problem, deleting the directory. The call to remove_directory was failing. I then began to debug the issue by adding some ?'s for status information and it started working. I reverted, built again and mine now works. Something silly going on, I'm not sure what but it doesn't smell good getlost

7. Comment by euphoric Nov 23, 2010

Just wanted to report that I was able to build with the latest revision (4273). I also got the "Could not delete build directory" message.

8. Comment by jimcbrown Nov 23, 2010

Adding milestone. Sounds like it might already be fixed in the latest svn rev, though we don't know exactly what the cause of the bug or the fix was...

9. Comment by SDPringle Nov 24, 2010

Although there is a can't delete build directory issue. The issue in this ticket's title is now fixed.


Quick Links

User menu

Not signed in.

Misc Menu