forum-msg-id-136073-edit

Original date:2021-04-08 11:36:57 Edited by: ghaberek Subject: Re: Compile problem

It occurred to me that if you're already using the translator then you should be able to rebuild the library from source. This should resolve both the "-no-pie" problem and this libc issue.

# Clone the Euphoria source repo 
git clone --depth=1 https://github.com/OpenEuphoria/euphoria OpenEuphoria/euphoria 
 
# Change to the source directory 
cd OpenEuphoria/euphoria/source 
 
# Run the configure script 
./configure 
 
# Build the library 
make library 
 
# Backup the installed library (optional) 
sudo mv /usr/local/euphoria-4.1.0-Linux-x64/bin/eu.a{,.bak} 
 
# Install the new library 
sudo cp build/eu.a /usr/local/euphoria-4.1.0-Linux-x64/bin/ 

I tested this on Linux Mint 20.1 which is based on Ubuntu 20.04. Hope that helps.

-Greg

Not Categorized, Please Help

Search



Quick Links

User menu

Not signed in.

Misc Menu