forum-msg-id-135641-edit

Original date:2021-01-31 17:08:15 Edited by: irv Subject: Re: sh: 1: /media/mycomputer/Seagate: not found

petelomax said...
irv said...

As far as I can tell, there is no p64 that is executable and no need to rename anything.

It's just a packaging file. Here, on windows, I run "p -c -norun p64.exu" and upload the resulting p64 to the website, which contains the instructions "wget http://phix.x10.mx/p64" and "mv p64 phix/p".

OK, but why or how is _tom running ./p64 ? If in fact "mv p64 phix/p" succeeded, then trying to run ./p64 would result in an error (./p64: No such file or directory). Since it does (sometimes) work for him, that indicates that the "mv p64 phix/p" failed. In that case, one might wonder what else may have also failed.

petelomax said...

Now then dear, what's the bad news then?

The update completely destroyed object inheritance. Example: a GtkWindow has a property called "border_width"; private integer border_width; and set_border_width() are implemented in GtkContainer.e (via GtkBin.e)

Window win = new() 
  win.border_width = 10 

Yesterday, all is fine. win.border_width = 10 worked. Today, I get a message: attempt to modify private field (border_width)

Worse, if I make the field public, it says: Segmentation fault (core dumped)

Worse than that, sometimes the error is: Cannot open /home/irv/pgtk/GtkContainer.ex

What? There is no GtkContainer.ex, and none of my code tries to include an *.ex file. A "grep GtkContainer *" of the entire directory shows:

GtkBin.e:5:include GtkContainer.e 
GtkBox.e:4:include GtkContainer.e 
GtkContainer.e:2:-- GtkContainer  

Not Categorized, Please Help

Search



Quick Links

User menu

Not signed in.

Misc Menu