Original date:2014-07-14 02:59:54 Edited by: jimcbrown Subject: Re: Win32Lib and v4.1.0 (x64)

andi49 said...
ZNorQ said...


I get the following errors when I run software using Win32Lib with openEuphoria v4.1.0.

First screen to pop up is the "Win32Lib AppWindow - Fatal Error", then the shutdown (which I cancel, but still closes down certain processes and basically results in a required restart), and lastly the cmd-window.

When running same code using v4.0.5, I do not get these errors. Anyone got any idea what this could be...?

Kenneth aka ZNorQ.

PS! Sorry if the issue have been brought up before; tried searching for similar occurrences/reports.

edit by moderator: fixed version numbers


I can reproduce this on WIn8.1

But only if i try a 64bit Version of the Euphoria Interpreter.

Is it this what you are trying todo? Running Win32lib with an 64bit Interpreter?

I do not think you can do this without completely rewritng Win32lib ;) Handles and Pointers for the WinApi are now 64bit and there are all Hardcoded with 32bit in Win32lib.

I think MattLewis has a Version of Win32lib using his Struct-Branch of Euphoria. Maybe this works.

I think it is this one:


Yes, I'm using the 64bit version of v4.10 - but I went back to v4.05 and it now works. Seems like a logical explanation you gave me, so I'll give v4.10 32bit a try and see how that handles.

Thanks for the feedback.

Regards Kenneth aka ZNorQ.

Not Categorized, Please Help


Quick Links

User menu

Not signed in.

Misc Menu