1. Can't install phix

Tried to install 64-bit linux, everything goes ok until:

./p -test 
seqmentation fault 
Mint 19.3
Linux irv-desktop 5.0.0-32-generic #34~18.04.2-Ubuntu SMP Thu Oct 10 10:36:02 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

new topic     » topic index » view message » categorize

2. Re: Can't install phix

Yep, Otto reported the same thing earlier today:

the p executable 64bit V1.0.1 worked fine on Ubuntu 20.04.x. Yesterday I upgraded to Ubuntu 22.04 - the p executable crashes with a segmentation violation ...

Something similar happened a while back, eventually traced to the kernel being recompiled with different stack alignment options.
Be warned it took me a very long time to figure out a fix for that - so unfortunately I'm probably not the best person to ask! ! !
You could try googling for recent kernel changes, or maybe see if gdb and friends offer any better clues...

Probably something on https://kernelnewbies.org/LinuxChanges - one of the tips on that site is to run something called dmesg...

You may want to look into https://support.starlabs.systems/kb/guides/install-an-alternative-kernel to see whether an older or newer kernel fixes things.

Also, "./phix -d p64.exu" should produce a list.asm if you've (somehow) got a machine address where it's going wrong,
though you may very well need to generate that on a different machine.

new topic     » goto parent     » topic index » view message » categorize

Search



Quick Links

User menu

Not signed in.

Misc Menu